Tomcat error APR version 1.1.22


¿Como solucionar este error?

26-mar-2014 9:21:21 org.apache.catalina.core.AprLifecycleListener init
GRAVE: Se encuentra instalada una versión incompatible 1.1.22 de la biblioteca nativa APR de Apache Tomcat, mientras que Tomcat necesita la versión 1.1.24

Para Windows:
te descargas de aqui, la “tomcat-native-1.1.29-win32-bin.zip”. Descomprimes y copias en la carpeta tomcat/bin el tcnative-1.dll

En esta pagina dicen como compilar e instalar las fuentes.

Para linux (no lo he probado)

#!/bin/bash
# By Guido Medina
# http://stackoverflow.com/questions/18109722/an-incompatible-version-1-1-22-of-the-apr-based-apache-tomcat-native-library-is

export APR_PATH=/usr/bin/apr-1-config
export JAVA_HOME=/opt/java
export TOMCAT_HOME=/opt/tomcat
export INSTALL_PREFIX=/usr

wajig install libaprutil1-dev make

cd /tmp
rm -Rf tomcat-native-*
tar -zxf $TOMCAT_HOME/bin/tomcat-native.tar.gz
cd /tmp/tomcat-native-*/jni/native

./configure --with-apr=$APR_PATH --with-java-home=$JAVA_HOME --prefix=$INSTALL_PREFIX
make && make install

sacado de sourceforge

Anuncios
Tomcat error APR version 1.1.22